Menu

Script de Backup automático para Mikrotik

2 noviembre, 2016 - Guias, How-To, Tutoriales, Linux
Script de Backup automático para Mikrotik

Este es un sencillo script + cron que funciona de la siguiente mantera:

Vale aclarar que el usuario de FTP es igual que el nombre del router.


##Configuracion de e-mail y BKP
/tool e-mail
set address=IPSMTPserver from=alertas@domino.com.ar password=epel123 user=alertas@dominio.com.ar
/system script
add name=FTP-Backup owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=”# Sistema automatizado de BKP p\
or FTP\r\
\n:local varIdentity\r\
\n:local varDate\r\
\n:local varMonth\r\
\n:local varDay\r\
\n:local varYear\r\
\n:local varFileName\r\
\n:local varIdentity [/system identity get name] \r\
\n:local varDate [/system clock get date]\r\
\n:local varMonth [:pick \$varDate 0 3]\r\
\n:local varDay [:pick \$varDate 4 6]\r\
\n:local varYear [:pick \$varDate 7 11]\r\
\n:local varFileName ([\$varIdentity].\”-\”.[\$varMonth].\”-\”.[\$varDay].\”-\”.[\$varYear].\”.\”.[/system clock get time])\r\
\n# Exporto la configuracion\r\
\n/ expor file=[\$varFileName]\r\
\n# Hago un backup\r\
\n/system backup save name=[\$varFileName] dont-encrypt=yes\r\
\n##Envio los archivos de configuracion y BKP por FTP\r\
\n/too fetch address=FTPserverIP src-path=([\$varFileName].\”.rsc\”) mode=ftp user=[\$varIdentity] password=ftp123 upload=yes dst-p\
ath=([\$varFileName].\”.rsc\”)\r\
\n/too fetch address=FTPserverIP src-path=([\$varFileName].\”.backup\”) mode=ftp user=[\$varIdentity] password=ftp123 upload=yes ds\
t-path=([\$varFileName].\”.backup\”)\r\
\n\r\
\n##Limpio los bkps generados\r\
\n/file remove ([\$varFileName].\”.rsc\”)\r\
\n/file remove ([\$varFileName].\”.backup\”)\r\
\n/log info message=\”System Backup\”\r\
\n\r\
\n#Envio notificacion por correo\r\
\n/tool e-mail send to=epel@dominio.com.ar cc=fulano@mengano.com.ar subject=\”Bkp \$varFileName\” body=\”El bkp se realizo correctam\
ente\”\r\
\n”
/system scheduler
add interval=1d name=”BKP diario” on-event=”/system script run FTP-Backup” policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=oct/17/2016 start-time=02:00:00

 


Espero les sirva y cualquier modificación es más que bienvenida!

Saludos!

Dejá un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *

*